Skip to content
Permalink
develop
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
#
# This file is autogenerated by pip-compile
# To update, run:
#
# pip-compile dev-requirements.in
#
alabaster==0.7.12
# via sphinx
apipkg==1.5
# via execnet
appdirs==1.4.4
# via
# black
# virtualenv
astroid==2.6.6
# via pylint
atomicwrites==1.4.0
# via pytest
attrs==20.3.0
# via
# -c requirements.txt
# pytest
babel==2.9.0
# via sphinx
black==21.7b0
# via -r dev-requirements.in
bleach==3.3.0
# via readme-renderer
boto3==1.18.14
# via -r dev-requirements.in
botocore==1.21.14
# via
# boto3
# s3transfer
certifi==2020.12.5
# via
# -c requirements.txt
# requests
cfgv==3.2.0
# via pre-commit
charset-normalizer==2.0.3
# via
# -c requirements.txt
# requests
click==7.1.2
# via
# -c requirements.txt
# -r dev-requirements.in
# black
# pip-tools
codacy-coverage==1.3.11
# via -r dev-requirements.in
colorama==0.4.4
# via
# -c requirements.txt
# pylint
# pytest
# sphinx
# twine
coverage==5.5
# via
# -r dev-requirements.in
# pytest-cov
dataclasses==0.8
# via black
distlib==0.3.1
# via virtualenv
docutils==0.16
# via
# readme-renderer
# sphinx
execnet==1.8.0
# via pytest-xdist
filelock==3.0.12
# via virtualenv
flake8==3.9.2
# via -r dev-requirements.in
gitdb==4.0.7
# via gitpython
gitpython==3.1.18
# via -r dev-requirements.in
identify==2.2.4
# via pre-commit
idna==2.10
# via
# -c requirements.txt
# requests
# yarl
imagesize==1.2.0
# via sphinx
importlib-metadata==4.6.3
# via
# -c requirements.txt
# flake8
# keyring
# pep517
# pluggy
# pre-commit
# pytest
# twine
# virtualenv
importlib-resources==5.2.2
# via
# -c requirements.txt
# pre-commit
# virtualenv
iniconfig==1.1.1
# via pytest
isort==5.9.3
# via
# -r dev-requirements.in
# pylint
jinja2==3.0.1
# via
# -c requirements.txt
# sphinx
jmespath==0.10.0
# via
# boto3
# botocore
keyring==23.0.1
# via twine
lazy-object-proxy==1.6.0
# via astroid
markupsafe==2.0.0
# via
# -c requirements.txt
# jinja2
mccabe==0.6.1
# via
# flake8
# pylint
multidict==5.1.0
# via yarl
mypy-extensions==0.4.3
# via
# black
# mypy
mypy==0.812
# via sqlalchemy-stubs
nodeenv==1.6.0
# via pre-commit
packaging==20.9
# via
# bleach
# pytest
# sphinx
pathspec==0.8.1
# via black
pep517==0.10.0
# via pip-tools
pip-tools==6.2.0
# via -r dev-requirements.in
pkginfo==1.7.0
# via twine
pluggy==0.13.1
# via pytest
pre-commit==2.13.0
# via -r dev-requirements.in
py==1.10.0
# via
# pytest
# pytest-forked
pycodestyle==2.7.0
# via flake8
pyflakes==2.3.1
# via flake8
pygments==2.8.1
# via
# readme-renderer
# sphinx
pylint==2.9.6
# via -r dev-requirements.in
pyparsing==2.4.7
# via
# -c requirements.txt
# packaging
pytest-cov==2.12.1
# via -r dev-requirements.in
pytest-forked==1.3.0
# via pytest-xdist
pytest-runner==5.3.1
# via -r dev-requirements.in
pytest-xdist==2.3.0
# via -r dev-requirements.in
pytest==6.2.4
# via
# -r dev-requirements.in
# pytest-cov
# pytest-forked
# pytest-xdist
python-dateutil==2.8.2
# via
# -c requirements.txt
# botocore
pytz==2021.1
# via
# -c requirements.txt
# babel
pyyaml==5.4.1
# via
# -c requirements.txt
# pre-commit
# vcrpy
readme-renderer==29.0
# via twine
regex==2021.4.4
# via black
requests-toolbelt==0.9.1
# via twine
requests==2.26.0
# via
# -c requirements.txt
# codacy-coverage
# requests-toolbelt
# sphinx
# twine
rfc3986==1.4.0
# via twine
s3transfer==0.5.0
# via boto3
six==1.15.0
# via
# -c requirements.txt
# bleach
# python-dateutil
# readme-renderer
# vcrpy
# virtualenv
smmap==4.0.0
# via gitdb
snowballstemmer==2.1.0
# via sphinx
sphinx==4.1.2
# via -r dev-requirements.in
sphinxcontrib-applehelp==1.0.2
# via sphinx
sphinxcontrib-devhelp==1.0.2
# via sphinx
sphinxcontrib-htmlhelp==2.0.0
# via sphinx
sphinxcontrib-jsmath==1.0.1
# via sphinx
sphinxcontrib-qthelp==1.0.3
# via sphinx
sphinxcontrib-serializinghtml==1.1.5
# via sphinx
sqlalchemy-stubs==0.4
# via -r dev-requirements.in
toml==0.10.2
# via
# pep517
# pre-commit
# pylint
# pytest
# pytest-cov
tomli==1.2.0
# via black
tqdm==4.60.0
# via twine
twine==3.4.2
# via -r dev-requirements.in
typed-ast==1.4.3
# via
# astroid
# black
# mypy
typing-extensions==3.10.0.0
# via
# -c requirements.txt
# astroid
# black
# gitpython
# importlib-metadata
# mypy
# sqlalchemy-stubs
# yarl
urllib3==1.26.4
# via
# -c requirements.txt
# botocore
# requests
vcrpy==4.1.1
# via -r dev-requirements.in
virtualenv==20.4.4
# via pre-commit
webencodings==0.5.1
# via
# -c requirements.txt
# bleach
wheel==0.36.2
# via
# -r dev-requirements.in
# pip-tools
wrapt==1.12.1
# via
# astroid
# vcrpy
yarl==1.6.3
# via vcrpy
zipp==3.5.0
# via
# -c requirements.txt
# importlib-metadata
# importlib-resources
# pep517
# The following packages are considered to be unsafe in a requirements file:
# pip
# setuptools