Skip to content

OS command injection in BibTeX-Ruby

high severity CVE-2019-10780 published Feb 14, 2020 • updated Feb 14, 2020
Packages Affected versions Patched versions
bibtex-ruby (RubyGems) <= 5.0.1 5.1.0

BibTeX-ruby before 5.1.0 allows shell command injection due to unsanitized user input being passed directly to the built-in Ruby Kernel.open method through BibTeX.open.

References

You can’t perform that action at this time.